Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
X1000 not working
#1
hey guys,

My x1000 wont even load past the boot screen.

I took the DC plug out, wait 5 mins, plugged the power back on and nothing.......blank screen. i waited an hour, and still blank screen.

I did it a few times before i came to post here.

any suggestions or help?

Thanks
Reply
#2
Unfortunately I would suspect a hardware failure. Regrettably do not expect any help from MeLE, I had a failure with the same symptoms and got no help - so I posted it back to the factory (it was still in the warranty period and as it was dead I had nothing to lose). I was able to confirm it had been received by messaging through Aliexpress where it was bought. Then nothing, no replies to my messages, and that was 12 months or so ago. So good luck!
Reply
#3
(06-17-2016, 05:09 AM)adaveak Wrote:  Unfortunately I would suspect a hardware failure.  Regrettably do not expect any help from MeLE, I had a failure with the same symptoms and got no help - so I posted it back to the factory (it was still in the warranty period and as it was dead I had nothing to lose). I was able to confirm it had been received by messaging through Aliexpress where it was bought.  Then nothing, no replies to my messages, and that was 12 months or so ago.  So good luck!

thats sucks! this product was good for a solid 4 months, always updated, no electrical failure...nothing! out of no where, stopped turning on! what a let down. thanks for letting me know!
Reply
#4
I agree, nothing wrong with the product - I bought three including the one that failed. Just the lack of support lets them down, I wouldn't buy anything from them now.
Reply
#5
im so dissapointed i bought this mediaplayer also, doesnt work that well, and the support is just horrible...it was the cheapest and did hope it would be a good player, but its not, so many issues all the time...no, this was the first last mele product for me
Reply
#6
(06-22-2016, 03:55 AM)blade_997 Wrote:  im so dissapointed i bought this mediaplayer also, doesnt work that well, and the support is just horrible...it was the cheapest and did hope it would be a good player, but its not, so many issues all the time...no, this was the first last mele product for me


Do yourself a favor and buy a Himedia player, Best support in the buis.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)